Jump to content
IPS Invision Community
Sign in to follow this  
Maza_Haker

Переход с IPB 3.4.6 на IPS 4.x.x

Recommended Posts

Maza_Haker

Всем привет, подскажите как перейти с версии ipb 3.4.6 на ips последнюю версию, может кто помочь?

Share this post


Link to post
Share on other sites
salex

Да вот проблемка нарисовалась с конвертацией базы. ошибки, ошибки и все...)

Share this post


Link to post
Share on other sites
salex

Да уже откатил назад с бэкапа. Так не вспомню. Была даже мысль на чистую 4-ку экспортировать часть таблиц БД. Форумы, топики и юзеров. Все остальное - шлак. Но не вышел аленький цветочек)) Как с тобой связаться? А то тут доступно 0 сообщений в день у меня)

Share this post


Link to post
Share on other sites
salex

Ок. Сейчас бэкап делаю новый. Последнюю попытку сделаю и сдамся) Наверное)

  • Нравится 1

Share this post


Link to post
Share on other sites
salex

Первая ошибка

Duplicate entry 'External' for key 'PRIMARY' 
/var/www/vh126273/data/www/****/applications/core/setup/upg_40000/upgrade.php::908
INSERT INTO `core_login_handlers` ( `login_settings`, `login_key`, `login_enabled`, `login_order` ) VALUES ( ?, ?, ?, ? )

Следом 

Table 'vh126273_1.login_methods' doesn't exist 
/var/www/vh126273/data/www/****/system/Db/Select.php::433
SELECT * FROM `login_methods`

и после ее уже не дает дальше обновить

Edited by salex

Share this post


Link to post
Share on other sites
salex

Сделал копию форума на поддомен. Перенес бд и т.п. Удалил все приложения и отключил все куки. Оставил только стандартный скин. Обновился сначала до 3.4.9. Все удачно. Потом сверху 4.2.2. и все теже ошибки. 

Share this post


Link to post
Share on other sites
WOLF

зайти в БД выбрать все таблицы и внизу нажать "восстановить таблицы" 

Share this post


Link to post
Share on other sites
salex

Да делал кучу раз. Ошибки говорят, что нет `login_methods` в БД. И там действительно нет такого.

Share this post


Link to post
Share on other sites
WOLF
Цитата

Если не хватает каких-либо таблиц или столбцов, их нужно восстановить из оригинального дистрибутива.

 

Share this post


Link to post
Share on other sites
salex

и как это сделать? я читал эту фразу, но ответа так и не нашел

Share this post


Link to post
Share on other sites
WOLF
Только что, salex сказал:

и как это сделать? я читал эту фразу, но ответа так и не нашел

устанавливаете с нуля форум, берете из его БД нужные таблицы и заливаете их к себе 

  • Спасибо 1

Share this post


Link to post
Share on other sites
salex

Прикольно. Экспортировал таблицу login_methods из дистрибута. 

При обновлении таблицу эту удаляет и пишет ошибку первую ошибку Duplicate entry 'External' for key 'PRIMARY'

Потом снова импортируешь таблицу и снова при продолжении обновления удаляется таблица. Чертовщина какая-то))

Share this post


Link to post
Share on other sites
salex

Дошел уже до следующей ошибки)

Unknown column 'sys_module_admin' in 'where clause' 
/var/www/vh126273/data/www/*****/applications/core/setup/upg_40000/queries.json - query #5
UPDATE `core_modules` core_modules  SET `sys_module_area`=? WHERE sys_module_admin=1 

 

Share this post


Link to post
Share on other sites
WOLF

Отсутствует столбец в таблице

  • Спасибо 1

Share this post


Link to post
Share on other sites
salex

исправил.

Потом 

Can't find file: './vh126273_5/skin_collections.frm' (errno: 2 - No such file or directory) 

 

Share this post


Link to post
Share on other sites
Sipsb

Чуфыр меня молнией по башке, вы че тут мудрите? @WOLF если не вкурсе как это делается и убираются ошибки в базах, то не нужно советовать! С ума посходили.

  • Смех 1

Share this post


Link to post
Share on other sites
salex

Часть ошибок сняли ( помог newbie)  в /applications/core/setup/upg_40000/upgrade.php

Еще дальше ошибки посыпались))

Share this post


Link to post
Share on other sites
salex

Обновился вроде. Продолжаем наблюдение)

Share this post


Link to post
Share on other sites
salex

Вроде бы обновился, но не могу понять почему папки с css_built и javascript_core создаются в папке uploads, а внешний вид админки и форума без css. В консоли браузера показывает ошибки, что не может найти css_built но не в папке uploads, а в корне. В настройках везде прописаны пути до uploads. (подопечный - forum.мойсайт) 

  • Смех 1

Share this post


Link to post
Share on other sites
salex

Короче все гуд. Только я так понял download файлы с 3-ки надо заново заливать?

Share this post


Link to post
Share on other sites
salex

У меня была залита литература. Если попытаться скачать, то пишет файл не найден. Как и на всех форумах по ipb. Старые файлы не грузятся с 3-ки.

з.ы. А профили закрыть от гостей можно как-то? А то у меня много людей не хотят светиться.

Edited by salex

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • Justice
      By Justice
      Пара вопросов: 
      1. Как сделать запуск форума site.com/forums/ при обращении к site.com? 
      2. Почему-то в уведомлениях на почту пользователям (уведомления о новых сообщениях, например) имя отправителя (служебный аккаунт) пишет символами. То же самое с наименованием форума в мою.версии.
      3. Где редактировать вид мобильной версии?
       
      Заранее благодарю.
×
×
  • Create New...